svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
locale.h(3head)
locale.h(3HEAD) Headers locale.h(3HEAD)
NAME
locale.h, locale - category macros
SYNOPSIS
#include <locale.h>
DESCRIPTION
The <locale.h> header provides a definition for the lconv structure,
which includes the following members. (See the definition of LC_MONE‐
TARY in locale(7).)
char *currency_symbol
char *decimal_point
char frac_digits
char *grouping
char *int_curr_symbol
char int_frac_digits
char int_n_cs_precedes
char int_n_sep_by_space
char int_n_sign_posn
char int_p_cs_precedes
char int_p_sep_by_space
char int_p_sign_posn
char *mon_decimal_point
char *mon_grouping
char *mon_thousands_sep
char *negative_sign
char n_cs_precedes
char n_sep_by_space
char n_sign_posn
char *positive_sign
char p_cs_precedes
char p_sep_by_space
char p_sign_posn
char *thousands_sep
The <locale.h> header defines NULL (as defined in <stddef.h>) and the
following as macros:
LC_ALL
LC_COLLATE
LC_CTYPE
LC_MESSAGES
LC_MONETARY
LC_NUMERIC
LC_TIME
The preceding expand to distinct integer constant expressions, for use
as the first argument to the setlocale() function. See setlocale(3C).
The <locale.h> header contains the following macros representing bit‐
masks for use with the newlocale() function for each supported locale
category:
LC_COLLATE_MASK
LC_CTYPE_MASK
LC_MESSAGES_MASK
LC_MONETARY_MASK
LC_NUMERIC_MASK
LC_TIME_MASK
In addition, a macro to set the bits for all categories set is defined:
LC_ALL_MASK
The <locale.h> header defines LC_GLOBAL_LOCALE, a special locale object
descriptor used by the duplocale() and uselocale() functions.
The <locale.h> header defines the locale_t type, representing a locale
object.
Additional macro definitions, beginning with the characters LC_ and an
uppercase letter, can also be specified here.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
duplocale(3C), freelocale(3C), localeconv(3C), newlocale(3C), setlo‐
cale(3C), uselocale(3C), stddef.h(3HEAD), attributes(7), locale(7),
standards(7)
Oracle Solaris 11.4 1 Oct 2014 locale.h(3HEAD)