svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
listen(3c)
Standard C Library Functions listen(3C)
NAME
listen - listen for socket connections and limit the queue of incoming
connections
SYNOPSIS
#include <sys/socket.h>
int listen(int socket, int backlog);
DESCRIPTION
The listen() function marks a connection-mode socket, specified by the
socket argument, as accepting connections, and limits the number of
outstanding connections in the socket's listen queue to the value spec‐
ified by the backlog argument.
If listen() is called with a backlog argument value that is less than
0, the function sets the length of the socket's listen queue to 0.
The implementation may include incomplete connections in the queue sub‐
ject to the queue limit. The implementation may also increase the spec‐
ified queue limit internally if it includes such incomplete connections
in the queue subject to this limit.
Implementations may limit the length of the socket's listen queue. If
backlog exceeds the implementation-dependent maximum queue length, the
length of the socket's listen queue will be set to the maximum sup‐
ported value.
The socket in use may require the process to have appropriate privi‐
leges to use the listen() function.
RETURN VALUES
Upon successful completions, listen() returns 0. Otherwise, −1 is
returned and errno is set to indicate the error.
ERRORS
The listen() function will fail if:
EBADF The socket argument is not a valid file descriptor.
EDESTADDRREQ The socket is not bound to a local address, and the
protocol does not support listening on an unbound
socket.
EINVAL The socket is already connected.
ENOTSOCK The socket argument does not refer to a socket.
EOPNOTSUPP The socket protocol does not support listen().
The listen() function may fail if:
EACCES The calling process does not have the appropriate privi‐
leges.
EINVAL The socket has been shut down.
ENOBUFS Insufficient resources are available in the system to com‐
plete the call.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
accept(3C), connect(3C), socket(3C), attributes(7), standards(7)
HISTORY
The listen() function has been present since the initial release of
Solaris.
Oracle Solaris 11.4 2 Feb 2021 listen(3C)