svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
libtecla(3lib)
libtecla(3LIB) Interface Libraries libtecla(3LIB)
NAME
libtecla - interactive command line input library
SYNOPSIS
cc [ flag... ] file... -ltecla [ library... ]
#include <libtecla.h>
DESCRIPTION
This library provides programs with interactive command line editing
facilities, similar to those of the UNIX tcsh shell. In addition to
simple command-line editing, it supports recall of previously entered
command lines, TAB completion of file names or other tokens, and in-
line wildcard expansion of filenames. The internal functions that per‐
form file-name completion and wild-card expansion are also available
externally for optional use by the calling program.
Thread Safety
The terminfo functions setupterm(3CURSES), tigetstr(3CURSES), tiget‐
num(3CURSES), and tputs(3CURSES) are not reentrant. This condition,
however, should not prevent use of this library in threaded applica‐
tions, since few applications will want to interact with multiple ter‐
minals.
INTERFACES
The shared object libtecla.so.1 provides the public interfaces defined
below. See Intro(3) for additional information on shared object inter‐
faces.
tab(); lw(2.75i) lw(2.75i) lw(2.75i) lw(2.75i) cfc_file_startcfc_lit‐
eral_escapes cfc_set_check_fncpl_add_completion cpl_check_execpl_com‐
plete_word cpl_file_completionscpl_last_error cpl_list_comple‐
tionscpl_recall_matches cpl_record_errordel_CplFileConf del_Expand‐
Filedel_GetLine del_PathCachedel_PcaPathConf del_WordComple‐
tionef_expand_file ef_last_erroref_list_expansions gl_aban‐
don_linegl_append_history gl_automatic_historygl_bind_keyseq
gl_catch_blockedgl_change_terminal gl_clear_historygl_comple‐
tion_action gl_configure_getlinegl_customize_completion gl_dis‐
play_textgl_echo_mode gl_erase_terminalgl_error_message
gl_get_linegl_group_history gl_handle_signalgl_ignore_signal gl_inac‐
tivity_timeoutgl_io_mode gl_last_signalgl_limit_history gl_list_sig‐
nalsgl_load_history gl_lookup_historygl_normal_io gl_pend‐
ing_iogl_prompt_style gl_query_chargl_range_of_history
gl_raw_iogl_read_char gl_register_actiongl_replace_prompt
gl_resize_historygl_return_status gl_save_historygl_set_term_size
gl_show_historygl_size_of_history gl_state_of_historygl_terminal_size
gl_toggle_historygl_trap_signal gl_tty_signalsgl_watch_fd libte‐
cla_versionnew_CplFileConf new_ExpandFilenew_GetLine new_Path‐
Cachenew_PcaPathConf new_WordCompletionpca_last_error
pca_lookup_filepca_path_completions pca_scan_pathpca_set_check_fn
ppc_file_startppc_literal_escapes
FILES
/usr/lib/libtecla.so.1 shared object
/usr/lib/64/libtecla.so.1 64-bit shared object
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE
TYPEATTRIBUTE VALUE _ Availabilitysystem/library Interface Stabil‐
ityCommitted _ MT-LevelMT-Safe
SEE ALSO
enhance(1), Intro(3), cpl_complete_word(3TECLA),
ef_expand_file(3TECLA), gl_get_line(3TECLA), gl_io_mode(3TECLA),
pca_lookup_file(3TECLA), attributes(7), tecla(7)
Solaris 11.4 1 Jun 2004 libtecla(3LIB)