svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
libsysobj(3lib)
libsysobj(3LIB) Interface Libraries libsysobj(3LIB)
NAME
libsysobj - system object database library
SYNOPSIS
#include <sysobj.h>
cc [ flag... ] file... -lsysobj [ library... ]
DESCRIPTION
The functions in this library perform operations on the system object
database, a database of system objects, their identifying properties,
and namespaces.
The library defines the following handle for an object in the database:
sysobj_t handle for an object in the database
Each object in the database belongs to at least one class, the primary
class, which is specified when it is created. Objects can belong to
multiple classes, but have only one primary class.
An object can, as a member of a certain class, appear in a number of
namespaces, where it is identified by one or more aliases. An object
may have a number of properties, subdivided in to property classes.
The library supports the following operations:
o Create or destroy an object
o Add or remove an alias for an object
o Add or remove a property for an object
o Look up objects by their aliases and/or properties
o Retrieve aliases or properties for an object
o Watch events for certain objects or classes of objects, and
retrieve information on those events
INTERFACES
The shared object libsysobj.so.1 provides the public interfaces defined
below. For more information on shared object interfaces, see the
intro(3) man page.
sysobj_create sysobj_destroy
sysobj_dup sysobj_free
sysobj_uuidstr sysobj_uuid
sysobj_lookup sysobj_find
sysobj_classes
sysobj_add_property sysobj_del_property
sysobj_del_property sysobj_properties
sysobj_get_property sysobj_nvl_prop_classes
sysobj_nvl_prop_list sysobj_nvl_prop_nvpair
sysobj_nvl_prop_value
sysobj_add_alias sysobj_del_alias
sysobj_aliases sysobj_nvl_alias_classes
sysobj_get_alias sysobj_nvl_alias_namespaces
sysobj_nvl_alias_array
sysobj_event_register sysobj_event_unregister
sysobj_event_watch sysobj_event_get
FILES
/lib/libsysobj.so.1 shared object
/lib/64/libsysobj.so.1 64-bit shared object
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library _ Interface Stabili‐
tyVolatile _ MT-LevelMT-Safe
SEE ALSO
intro(3), attributes(7), sysobj_create(3SYSOBJ),
sysobj_add_alias(3SYSOBJ), sysobj_add_property(3SYSOBJ),
sysobj_event_register(3SYSOBJ)
Oracle Solaris 11.4 28 Mar 2016 libsysobj(3LIB)