svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
libmd(3lib)
libmd(3LIB) Interface Libraries libmd(3LIB)
NAME
libmd - Message Digest library
SYNOPSIS
cc [ flag... ] file... -lmd [ library... ]
#include <md4.h>
#include <md5.h>
#include <sha1.h>
#include <sha2.h>
#include <sha3.h>
DESCRIPTION
Functions in this library provide hashing routines for MD4 (RFC1320),
MD5 (RFC1321), SHA1 (RFC3174), SHA224 (FIPS 180-2), SHA256 (FIPS
180-2), SHA384 (FIPS 180-2), SHA512 (FIPS 180-2), and SHA512/t (FIPS
180-4) for t = 224 and 256 and the SHA3 (FIPS 202) family of hash func‐
tions (224, 256, 384 and 512-bit versions).
INTERFACES
The shared object libmd.so.1 provides the public interfaces defined
below. See intro(3) for additional information on shared object inter‐
faces.
tab(); lw(2.75i) lw(2.75i) MD4FinalMD4Init MD4Updatemd5_calc
MD5FinalMD5Init MD5UpdateSHA1Final SHA1InitSHA1Update SHA224Final‐
SHA224Init SHA224UpdateSHA256Final SHA256InitSHA256Update SHA2Final‐
SHA2Init SHA2UpdateSHA384Final SHA384InitSHA384Update SHA512Final‐
SHA512Init SHA512UpdateSHA3Init SHA3UpdateSHA3Final
The shared object libmd.so.1 also provides these public interfaces that
implement variants of SHA-2 and may perform faster on some 64-bit pro‐
cessors:
tab(); lw(2.75i) lw(2.75i) SHA512_t_FinalSHA512_t_Init SHA512_t_Update
The digest values produced by the SHA512/224 and SHA512/256 functions
are not the same as those digest values produced by the corresponding
SHA2 functions.
SECURITY
The MD4 and MD5 algorithms are currently considered weak for crypto‐
graphic use. The algorithms should be used only for compatibility with
legacy systems or protocols.
The SHA1 algorithm is also believed to have some weaknesses. Migration
to one of the SHA2 algorithms—including SHA224, SHA256, SHA386 or
SHA512— or a member of the SHA3 family is highly recommended when com‐
patibility with data formats and on wire protocols permit doing so.
FILES
/lib/libmd.so.1 shared object
/lib/64/libmd.so.1 64-bit shared object
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Availabilitysystem/library/security/crypto _ Interface
StabilityCommitted _ MT-LevelMT-Safe
Oracle Solaris 11.4 27 Nov 2017 libmd(3LIB)