svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
lgrp_version(3lgrp)
Locality Group Library Functions lgrp_version(3LGRP)
NAME
lgrp_version - coordinate library and application versions
SYNOPSIS
cc [ flag ... ] file... -llgrp [ library ... ]
#include <sys/lgrp_user.h>
int lgrp_version(const int version);
DESCRIPTION
The lgrp_version() function takes an interface version number, version,
as an argument and returns an lgroup interface version. The version
argument should be the value of LGRP_VER_CURRENT bound to the applica‐
tion when it was compiled or LGRP_VER_NONE to find out the current
lgroup interface version on the running system.
RETURN VALUES
If version is still supported by the implementation, then lgrp_ver‐
sion() returns the requested version. If LGRP_VER_NONE is returned, the
implementation cannot support the requested version. The application
should be recompiled and might require further changes.
If version is LGRP_VER_NONE, lgrp_version() returns the current version
of the library.
EXAMPLES
Example 1 Test whether the version of the interface used by the caller
is supported.
The following example tests whether the version of the interface used
by the caller is supported:
#include <sys/lgrp_user.h>
if (lgrp_version(LGRP_VER_CURRENT) != LGRP_VER_CURRENT) {
fprintf(stderr, "Built with unsupported lgroup interface %d\n",
LGRP_VER_CURRENT);
exit (1);
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
lgrp_init(3LGRP), liblgrp(3LIB), attributes(7)
Oracle Solaris 11.4 16 Apr 2003 lgrp_version(3LGRP)