svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
lgrp_resources(3lgrp)
Locality Group Library Functions lgrp_resources(3LGRP)
NAME
lgrp_resources - get lgroup resources of given lgroup
SYNOPSIS
cc [ flag ... ] file... -llgrp [ library ... ]
#include <sys/lgrp_user.h>
int lgrp_resources(lgrp_cookie_t cookie, lgrp_id_t lgrp,
lgrp_id_t *lgrpids, uint_t count, lgrp_rsrc_t type);
DESCRIPTION
The lgrp_resources() function takes a cookie representing a snapshot of
the lgroup hierarchy obtained from lgrp_init(3LGRP) and returns the
number of resources in the lgroup specified by lgrp. The resources are
represented by a set of lgroups in which each lgroup directly contains
CPU and/or memory resources.
The type argument should be set to one of the following values to spec‐
ify whether the CPU or memory resources should be returned:
LGRP_RSRC_CPU /* CPU resources */
LGRP_RSRC_MEM /* Memory resources */
If the lgrpids[] argument is non-null and the count argument is non-
zero, lgrp_resources() stores up to the specified count of lgroup IDs
into the lgrpids[] array.
RETURN VALUES
Upon successful completion, lgrp_resources() returns the number of
lgroup resources. Otherwise, -1 is returned and errno is set to indi‐
cate the error.
ERRORS
The lgrp_resources() function will fail if:
EINVAL The specified cookie is NULL, or the lgroup ID or type is not
valid.
ESRCH The specified lgroup ID was not found.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
lgrp_children(3LGRP), lgrp_init(3LGRP), lgrp_parents(3LGRP),
liblgrp(3LIB), attributes(7)
Oracle Solaris 11.4 18 Jun 2012 lgrp_resources(3LGRP)