svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
lgrp_parents(3lgrp)
Locality Group Library Functions lgrp_parents(3LGRP)
NAME
lgrp_parents - get parents of given lgroup
SYNOPSIS
cc [ flag ... ] file... -llgrp [ library ... ]
#include <sys/lgrp_user.h>
int lgrp_parents(lgrp_cookie_t cookie, lgrp_id_t child,
lgrp_id_t *lgrp_array, uint_t lgrp_array_size);
DESCRIPTION
The lgrp_parents() function takes a cookie representing a snapshot of
the lgroup hierarchy obtained from lgrp_init(3LGRP) and returns the
number of parent lgroups of the specified lgroup. If lgrp_array is non-
null and the lgrp_array_size is non-zero, the array is filled with as
many of the parent lgroup IDs as will fit given the size of the array.
For the root lgroup, the number of parents returned is 0 and the
lgrp_array argument is not filled in.
RETURN VALUES
Upon successful completion, lgrp_parents() returns the number of parent
lgroup IDs. Otherwise, −1 is returned and errno is set to indicate the
error.
ERRORS
The lgrp_parents() function will fail if:
EINVAL The specified cookie is NULL or the lgroup ID is not valid.
ESRCH The specified lgroup ID was not found.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
lgrp_children(3LGRP), lgrp_init(3LGRP), lgrp_nlgrps(3LGRP),
liblgrp(3LIB), attributes(7)
Oracle Solaris 11.4 18 Jun 2012 lgrp_parents(3LGRP)