svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
lgrp_latency(3lgrp)
Locality Group Library Functions lgrp_latency(3LGRP)
NAME
lgrp_latency, lgrp_latency_cookie - get latency between two lgroups
SYNOPSIS
cc [ flag... ] file... -llgrp [ library... ]
#include <sys/lgrp_user.h>
int lgrp_latency_cookie(lgrp_cookie_t cookie, lgrp_id_t from,
lgrp_id_t to, lgrp_lat_between_t between);
int lgrp_latency(lgrp_id_t from, lgrp_id_t to);
DESCRIPTION
The lgrp_latency_cookie() function takes a cookie representing a snap‐
shot of the lgroup hierarchy obtained from lgrp_init(3LGRP) and returns
the latency value between a hardware resource in the from lgroup to a
hardware resource in the to lgroup. If from is the same lgroup as to,
the latency value within that lgroup is returned.
The between argument should be set to the following value to specify
between which hardware resources the latency should be measured:
LGRP_LAT_CPU_TO_MEM /* latency from CPU to memory */
The latency value is defined by the operating system and is platform-
specific. It can be used only for relative comparison of lgroups on the
running system. It does not necessarily represent the actual latency
between hardware devices, and it might not be applicable across plat‐
forms.
The lgrp_latency() function is similar to the lgrp_latency_cookie()
function, but returns the latency between the given lgroups at the
given instant in time. Since lgroups can be freed and reallocated, this
function might not be able to provide a consistent answer across calls.
For that reason, the lgrp_latency_cookie() function should be used in
its place.
RETURN VALUES
Upon successful completion, the latency value is returned. Otherwise −1
is returned and errno is set to indicate the error.
ERRORS
The lgrp_latency_cookie() and lgrp_latency() functions will fail if:
EINVAL The specified cookie is NULL, or the lgroup ID or value given
for the between argument is not valid.
ESRCH The specified lgroup ID was not found, the from lgroup does
not contain any CPUs, or the to lgroup does not have any mem‐
ory.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
lgrp_children(3LGRP), lgrp_init(3LGRP), lgrp_parents(3LGRP),
liblgrp(3LIB), attributes(7)
Oracle Solaris 11.4 27 Nov 2017 lgrp_latency(3LGRP)