svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
lgrp_children(3lgrp)
Locality Group Library Functions lgrp_children(3LGRP)
NAME
lgrp_children - get children of given lgroup
SYNOPSIS
cc [ flag ... ] file... -llgrp [ library ... ]
#include <sys/lgrp_user.h>
int lgrp_children(lgrp_cookie_t cookie, lgrp_id_t parent,
lgrp_id_t *lgrp_array, uint_t lgrp_array_size);
DESCRIPTION
The lgrp_children() function takes a cookie representing a snapshot of
the lgroup hierarchy retrieved from lgrp_init(3LGRP) and returns the
number of lgroups that are children of the specified lgroup. If the
lgrp_array and lgrp_array_size arguments are non-null, the array is
filled with as many of the children lgroup IDs as will fit, given the
size of the array.
RETURN VALUES
The lgrp_children() function returns the number of child lgroup IDs.
Otherwise, it returns −1 and sets errno to indicate the error.
ERRORS
The lgrp_children() function will fail if:
EINVAL The specified lgroup ID is not valid or the cookie is NULL.
ESRCH The specified lgroup ID was not found.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
lgrp_init(3LGRP), lgrp_nlgrps(3LGRP), lgrp_parents(3LGRP),
liblgrp(3LIB), attributes(7)
Oracle Solaris 11.4 18 Jun 2012 lgrp_children(3LGRP)