svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
lgrp_affinity_inherit_get(3lgrp)
Locality Group Library Functions
lgrp_affinity_inherit_get(3LGRP)
NAME
lgrp_affinity_inherit_get - get lgroup affinity inheritance
SYNOPSIS
cc [ flag ... ] file... -llgrp [ library ... ]
#include <sys/lgrp_user.h>
lgrp_aff_inherit_t lgrp_affinity_inherit_get(idtype_t idtype,
id_t id);
DESCRIPTION
The lgrp_affinity_inherit_get() function returns the lgroup affinity
inheritance of the specified process or thread. The lgroup affinities
can be inherited by child processes or threads across fork(2), exec(2),
pthread_create(3C), and thr_create(3C). By default, they are not inher‐
ited across fork(), pthread_create(), and thr_create(), but are inher‐
ited across the exec functions for compatibility.
If the idtype is P_PID, the lgroup affinity inheritance is retrieved
for one of the threads in the process with process ID (PID) id. The
lgroup affinity inheritance is gotten for the thread in the current
process with LWP ID id if idtype is P_LWPID. If id is P_MYID, then the
current thread or process is specified.
The lgrp_aff_inherit_t can be one of the following values:
LGRP_AFF_INHERIT_DEFAULT The lgroup affinity inheritance is set to
the default value for the specified process
or thread.
LGRP_AFF_INHERIT_NONE The lgroup affinities are not inherited
from the specified process or thread.
LGRP_AFF_INHERIT_FUTURE The lgroup affinities will be inherited by
future children of the specified process or
thread.
RETURN VALUES
Upon successful completion, lgrp_affinity_inherit_get() returns one of
the values described above for lgrp_aff_inherit_t. Otherwise, -1 is
returned and errno is set to indicate the error.
ERRORS
The lgrp_affinity_inherit_set() function will fail if:
EACCES Operation permission is denied to the calling process (see
Intro(2)).
EINVAL An invalid idtype or ID was given.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
Intro(2), exec(2), fork(2), pthread_create(3C), thr_create(3C),
lgrp_affinity_get(3LGRP), lgrp_affinity_inherit_set(3LGRP), lgrp_affin‐
ity_set(3LGRP), liblgrp(3LIB), attributes(7)
Oracle Solaris 11.4 2 June 2011
lgrp_affinity_inherit_get(3LGRP)