svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
iswalpha(3c)
Standard C Library Functions iswalpha(3C)
NAME
iswalpha, isenglish, isideogram, isnumber, isphonogram, isspecial,
iswalnum, iswascii, iswblank, iswcntrl, iswdigit, iswgraph, iswlower,
iswprint, iswpunct, iswspace, iswupper, iswxdigit, iswalpha_l, iswal‐
num_l, iswblank_l, iswcntrl_l, iswdigit_l, iswgraph_l, iswlower_l, isw‐
print_l, iswpunct_l, iswspace_l, iswupper_l, iswxdigit_l - wide-charac‐
ter code classification functions
SYNOPSIS
#include <wchar.h>
#include <wctype.h>
int iswalpha(wint_t wc);
int isenglish(wint_t wc);
int isideogram(wint_t wc);
int isnumber(wint_t wc);
int isphonogram(wint_t wc);
int isspecial(wint_t wc);
int iswalnum(wint_t wc);
int iswascii(wint_t wc);
int iswblank(wint_t wc);
int iswcntrl(wint_t wc);
int iswdigit(wint_t wc);
int iswgraph(wint_t wc);
int iswlower(wint_t wc);
int iswprint(wint_t wc);
int iswpunct(wint_t wc);
int iswspace(wint_t wc);
int iswupper(wint_t wc);
int iswxdigit(wint_t wc);
#include <wctype.h>
int iswalpha_l(wint_t wc, locale_t locale);
int iswalnum_l(wint_t wc, locale_t locale);
int iswblank_l(wint_t wc, locale_t locale);
int iswcntrl_l(wint_t wc, locale_t locale);
int iswdigit_l(wint_t wc, locale_t locale);
int iswgraph_l(wint_t wc, locale_t locale);
int iswlower_l(wint_t wc, locale_t locale);
int iswprint_l(wint_t wc, locale_t locale);
int iswpunct_l(wint_t wc, locale_t locale);
int iswspace_l(wint_t wc, locale_t locale);
int iswupper_l(wint_t wc, locale_t locale);
int iswxdigit_l(wint_t wc, locale_t locale);
DESCRIPTION
These functions whose names don't end with _l test whether wc is a
wide-character code representing a character of a particular class
defined in the LC_CTYPE category of the current locale.
In all cases, wc is a wint_t, the value of which must be a wide-charac‐
ter code corresponding to a valid character in the current locale or
must equal the value of the macro WEOF. If the argument has any other
values, the behavior is undefined.
iswalpha(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "alpha" in the program's
current locale.
isenglish(wc) Tests whether wc is a wide-character code represent‐
ing an English language character, excluding ASCII
characters.
isideogram(wc) Tests whether wc is a wide-character code represent‐
ing an ideographic language character, excluding
ASCII characters.
isnumber(wc) Tests whether wc is a wide-character code represent‐
ing digit [0−9], excluding ASCII characters.
isphonogram(wc) Tests whether wc is a wide-character code represent‐
ing a phonetic language character, excluding ASCII
characters.
isspecial(wc) Tests whether wc is a wide-character code represent‐
ing a special language character, excluding ASCII
characters.
iswalnum(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "alpha" or "digit" in the
program's current locale.
iswascii(wc) Tests whether wc is a wide-character code represent‐
ing an ASCII character.
iswblank(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "blank" in the program's
current locale. This function is not available to
applications conforming to standards prior to SUSv3.
See standards(7).
iswlower(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "lower" in the program's
current locale.
iswcntrl(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "cntrl" in the program's
current locale.
iswdigit(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "digit" in the program's
current locale.
iswgraph(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "graph" in the program's
current locale.
iswprint(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "print" in the program's
current locale.
iswpunct(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "punct" in the program's
current locale.
iswspace(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "space" in the program's
current locale.
iswupper(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "upper" in the program's
current locale.
iswxdigit(wc) Tests whether wc is a wide-character code represent‐
ing a character of class "xdigit" in the program's
current locale.
Functions whose name end with _l accept locale represented by second
argument <locale>, and tests wc in the locale specified, instead of in
the current locale. Except which locale the test is done in, same test
is done as done by corresponding function whose name doesn't end with
_l.
The behavior is undefined if the <locale> argument is the special
locale object LC_GLOBAL_LOCALE or is not a valid locale object handle.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilitySee below _ MT-LevelMT-
Safe
The iswalpha(), iswalnum(), iswblank(), iswcntrl(), iswdigit(), isw‐
graph(), iswlower(), iswprint(), iswpunct(), iswspace(), iswupper(),
and iswxdigit() iswalpha_l(), iswalnum_l(), iswblank_l(), iswcn‐
trl_l(), iswdigit_l(), iswgraph_l(), iswlower_l(), iswprint_l(), isw‐
punct_l(), iswspace_l(), iswupper_l(), and iswxdigit_l() functions are
Standard.
SEE ALSO
localedef(1), duplocale(3C), freelocale(3C), newlocale(3C), setlo‐
cale(3C), stdio(3C), uselocale(3C), ascii(7), attributes(7), stan‐
dards(7)
Oracle Solaris 11.4 21 Oct 2014 iswalpha(3C)