svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
isnan(3m)
Mathematical Library Functions isnan(3M)
NAME
isnan - test for NaN
SYNOPSIS
cc [ flag... ] file... -lm [ library... ]
#include <math.h>
int isnan(double x);
c99 [ flag... ] file... -lm [ library... ]
#include <math.h>
int isnan(real—floating x);
DESCRIPTION
In C90 mode, the isnan() function tests whether x is NaN.
In C99 mode, the isnan() macro determines whether its argument value is
NaN. First, an argument represented in a format wider than its semantic
type is converted to its semantic type. The determination is then based
on the type of the argument.
RETURN VALUES
Both the isnan() function and macro return non-zero if and only if x is
NaN.
ERRORS
No errors are defined.
WARNINGS
In C99 mode, the practice of explicitly supplying a prototype for
isnan() after the line
#include <math.h>
is obsolete and will no longer work.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
math.h(3HEAD), fpclassify(3M), isfinite(3M), isinf(3M), isnormal(3M),
signbit(3M), attributes(7), standards(7)
Solaris 11.4 27 Sept 2016 isnan(3M)