svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
isatty(3c)
Standard C Library Functions isatty(3C)
NAME
isatty - test for a terminal device
SYNOPSIS
#include <unistd.h>
int isatty(int fildes);
DESCRIPTION
The isatty() function tests whether fildes, an open file descriptor, is
associated with a terminal device.
RETURN VALUES
The isatty() function returns 1 if fildes is associated with a termi‐
nal; otherwise it returns 0 and may set errno to indicate the error.
ERRORS
The isatty() function may fail if:
EBADF The fildes argument is not a valid open file descriptor.
ENOTTY The fildes argument is not associated with a terminal.
USAGE
The isatty() function does not necessarily indicate that a human being
is available for interaction via fildes. It is quite possible that non-
terminal devices are connected to the communications line.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
ttyname(3C), attributes(7), standards(7)
Oracle Solaris 11.4 24 Jul 2002 isatty(3C)