svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
inttypes.h(3head)
inttypes.h(3HEAD) Headers inttypes.h(3HEAD)
NAME
inttypes.h, inttypes - fixed size integer types
SYNOPSIS
#include <inttypes.h>
DESCRIPTION
The <inttypes.h> header includes the <stdint.h> header.
The <inttypes.h> header includes a definition of the following type:
imaxdiv_t structure type that is the type of the value returned by
the imaxdiv() function.
The following macros are defined. Each expands to a character string
literal containing a conversion specifier, possibly modified by a
length modifier, suitable for use within the format argument of a for‐
matted input/output function when converting the corresponding integer
type. These macros have the general form of PRI (character string lit‐
erals for the fprintf() and fwprintf() family of functions) or SCN
(character string literals for the fscanf() and fwscanf() family of
functions), followed by the conversion specifier, followed by a name
corresponding to a similar type name in <stdint.h>. In these names, N
represents the width of the type as described in <stdint.h>. For exam‐
ple, PRIdFAST32 can be used in a format string to print the value of an
integer of type int_fast32_t.
The fprintf() macros for signed integers are:
PRIdN PRIdLEASTN PRIdFASTN PRIdMAX PRIdPTR
PRIiN PRIiLEASTN PRIiFASTN PRIiMAX PRIiPTR
The fprintf() macros for unsigned integers are:
PRIoN PRIoLEASTN PRIoFASTN PRIoMAX PRIoPTR
PRIuN PRIuLEASTN PRIuFASTN PRIuMAX PRIuPTR
PRIxN PRIxLEASTN PRIxFASTN PRIxMAX PRIxPTR
PRIXN PRIXLEASTN PRIXFASTN PRIXMAX PRIXPTR
The fscanf() macros for signed integers are:
SCNdN SCNdLEASTN SCNdFASTN SCNdMAX SCNdPTR
SCNiN SCNiLEASTN SCNiFASTN SCNiMAX SCNiPTR
The fscanf() macros for unsigned integers are:
SCNoN SCNoLEASTN SCNoFASTN SCNoMAX SCNoPTR
SCNuN SCNuLEASTN SCNuFASTN SCNuMAX SCNuPTR
SCNxN SCNxLEASTN SCNxFASTN SCNxMAX SCNxPTR
For each type that the implementation provides in <stdint.h>, the cor‐
responding fprintf() and fwprintf() macros must be defined. The corre‐
sponding fscanf() and fwscanf() macros must be defined as well, unless
the implementation does not have a suitable modifier for the type.
USAGE
The purpose of <inttypes.h> is to provide a set of integer types whose
definitions are consistent across machines and independent of operating
systems and other implementation idiosyncrasies. It defines, with a
typedef, integer types of various sizes. Implementations are free to
typedef them as ISO C standard integer types or extensions that they
support. Consistent use of this header greatly increases the portabil‐
ity of applications across platforms.
EXAMPLES
Example 1 Use of Macro
The following code uses one of the macros available through <int‐
types.h>.
#include <inttypes.h>
#include <wchar.h>
int main(void)
{
uintmax_t i = UINTMAX_MAX; // This type always exists.
wprintf("The largest integer value is %020"
PRIxMAX, "\n", i);
return 0;
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
imaxdiv(3C), attributes(7), standards(7)
Oracle Solaris 11.4 10 Sep 2004 inttypes.h(3HEAD)