svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
initgroups(3c)
Standard C Library Functions initgroups(3C)
NAME
initgroups - initialize the supplementary group access list
SYNOPSIS
#include <grp.h>
#include <sys/types.h>
int initgroups(const char *name, gid_t basegid);
DESCRIPTION
The initgroups() function reads the group database to get the group
membership for the user specified by name, and initializes the supple‐
mentary group access list of the calling process (see getgrnam(3C) and
getgroups(2)). The basegid group ID is also included in the supplemen‐
tary group access list. This is typically the real group ID from the
user database.
While scanning the group database, if the number of groups, including
the basegid entry, exceeds NGROUPS_MAX, subsequent group entries are
ignored.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The initgroups() function will fail and not change the supplementary
group access list if:
EPERM The {PRIV_PROC_SETID} privilege is not asserted in the effec‐
tive set of the calling process.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
getgroups(2), getgrnam(3C), attributes(7)
Oracle Solaris 11.4 22 Mar 2004 initgroups(3C)