svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
inet.h(3head)
inet.h(3HEAD) Headers inet.h(3HEAD)
NAME
inet.h, inet - definitions for internet operations
SYNOPSIS
#include <arpa/inet.h>
DESCRIPTION
The <arpa/inet.h> header defines the type in_port_t, the type
in_addr_t, and the in_addr structure, as described in in.h(3HEAD).
Inclusion of the <arpa/inet.h> header may also make visible all symbols
from in.h(3HEAD).
The following are declared as functions, and may also be defined as
macros:
in_addr_t inet_addr(const char *);
in_addr_t inet_lnaof(struct in_addr);
struct in_addr inet_makeaddr(in_addr_t, in_addr_t);
in_addr_t inet_netof(struct in_addr);
in_addr_t inet_network(const char *);
char *inet_ntoa(struct in_addr);
Default
For applications that do not require standard-conforming behavior
(those that use the socket interfaces described in section 3N of the
reference manual; see intro(3) and standards(7)), the following may be
declared as functions, or defined as macros, or both:
uint32_t htonl(uint32_t);
uint16_t htons(uint16_t);
uint32_t ntohl(uint32_t);
uint16_t ntohs(uint16_t);
Standard conforming
For applications that require standard-conforming behavior (those that
use the socket interfaces described in section 3XN of the reference
manual; see intro(3) and standards(7)), the following may be declared
as functions, or defined as macros, or both:
in_addr_t htonl(in_addr_t);
in_port_t htons(in_port_t);
in_addr_t ntohl(in_addr_t);
in_port_t ntohs(in_port_t);
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
htonl(3C), htonl(3C), inet_addr(3C), inet_addr(3C), in.h(3HEAD),
intro(3), attributes(7), standards(7)
Oracle Solaris 11.4 30 Aug 2002 inet.h(3HEAD)