svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
in.h(3head)
in.h(3HEAD) Headers in.h(3HEAD)
NAME
in.h, in - Internet Protocol family
SYNOPSIS
#include <netinet/in.h>
DESCRIPTION
The <netinet/in.h> header defines the following types through typedef:
in_port_t An unsigned integral type of exactly 16 bits.
in_addr_t An unsigned integral type of exactly 32 bits. The
<netinet/in.h> header defines the in_addr structure that
includes the following member:
The <netinet/in.h> header defines the in_addr structure that includes
the following member:
in_addr_t s_addr
The <netinet/in.h> header defines the type sa_family_t as described in
socket.h(3HEAD).
The <netinet/in.h> header defines the following macros for use as val‐
ues of the level argument of getsockopt() and setsockopt():
IPPROTO_IP Dummy for IP
IPPROTO_ICMP Control message protocol
IPPROTO_TCP TCP
IPPROTO_UDP User datagram protocol The <netinet/in.h> header
defines the following macros for use as destination
addresses for connect(), sendmsg(), and sendto():
INADDR_ANY Local host address
INADDR_BROADCAST Broadcast address
The <netinet/in.h> header defines the sockaddr_in structure that is
used to store addresses for the Internet protocol family. Values of
this type must be cast to struct sockaddr for use with the socket
interfaces.
Default
For applications that do not require standard-conforming behavior
(those that use the socket interfaces described in section (3SOCKET) of
the reference manual; see intro(3) and standards(7)), the
<netinet/in.h> header defines the sockaddr_in structure that includes
the following members:
sa_family_t sin_family
in_port_t sin_port
struct in_addr sin_addr
char sin_zero[8]
Standard conforming
For applications that require standard-conforming behavior (those that
use the socket interfaces described in section (3XNET) of the reference
manual; see intro(3) and standards(7)), the <netinet/in.h> header
defines the sockaddr_in structure that includes the following members:
sa_family_t sin_family
in_port_t sin_port
struct in_addr sin_addr
unsigned char sin_zero[8]
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
connect(3C), getsockopt(3C), sendmsg(3C), sendto(3C), setsockopt(3C),
socket.h(3HEAD), intro(3), standards(7), attributes(7)
Oracle Solaris 11.4 30 Aug 2002 in.h(3HEAD)