svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
iconv.h(3head)
iconv.h(3HEAD) Headers iconv.h(3HEAD)
NAME
iconv.h, iconv - codeset conversion facility
SYNOPSIS
#include <iconv.h>
DESCRIPTION
The <iconv.h> header defines the following types:
iconv_t Identifies an iconv code conversion from one codeset to
another.
cconv_t Identifies a cconv code conversion from one codeset to
another
The following symbolic constants are defined as possible values for an
operation request in query or setting of the iconv code conversion
behavior of the current conversion:
ICONV_GET_CONVERSION_BEHAVIOR
ICONV_GET_DISCARD_ILSEQ
ICONV_GET_TRANSLITERATE
ICONV_IGNORE_NULL
ICONV_REPLACE_INVALID
ICONV_SET_CONVERSION_BEHAVIOR
ICONV_SET_DISCARD_ILSEQ
ICONV_SET_TRANSLITERATE
ICONV_TRIVIALP
The aliases of the above for use with cconvctl() are also defined as
possible values for an operation request in query or setting of the
cconv code conversion behavior of the current conversion:
CCONV_GET_CONVERSION_BEHAVIOR
CCONV_GET_DISCARD_ILSEQ
CCONV_GET_TRANSLITERATE
CCONV_SET_CONVERSION_BEHAVIOR
CCONV_SET_DISCARD_ILSEQ
CCONV_SET_TRANSLITERATE
CCONV_TRIVIALP
The following symbolic constants are defined, zero or more of which can
be bitwise-inclusively OR'ed together to form the conversion behavior
settings for some of the above operation requests:
ICONV_CONV_ILLEGAL_DISCARD
ICONV_CONV_ILLEGAL_REPLACE_HEX
ICONV_CONV_ILLEGAL_RESTORE_HEX
ICONV_CONV_NON_IDENTICAL_DISCARD
ICONV_CONV_NON_IDENTICAL_REPLACE_HEX
ICONV_CONV_NON_IDENTICAL_RESTORE_HEX
ICONV_CONV_NON_IDENTICAL_TRANSLITERATE
The aliases of the above for use with cconv_open() and cconvctl() are
also defined as possible values that can be bitwise-inclusive OR'ed
together to form the conversion behavior settings for some of the above
operation requests:
CCONV_CONV_ILLEGAL_DISCARD
CCONV_CONV_ILLEGAL_REPLACE_HEX
CCONV_CONV_ILLEGAL_RESTORE_HEX
CCONV_CONV_NON_IDENTICAL_DISCARD
CCONV_CONV_NON_IDENTICAL_REPLACE_HEX
CCONV_CONV_NON_IDENTICAL_RESTORE_HEX
CCONV_CONV_NON_IDENTICAL_TRANSLITERATE
Additionally, for use with cconv_open(), the CCONV_CANONICAL_NAMES sym‐
bolic constant is defined so that, if necessary, it can also be bit‐
wise-inclusive OR'ed together with other constants to indicate to the
function that the tocode and the fromcode names supplied are canonical
names.
For more information on the above symbolic constants, see cconv(3C),
cconv_close(3C), cconv_open(3C), cconvctl(3C), iconv(3C), iconvctl(3C),
iconv_open(3C), and iconvstr(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
cconv(3C), cconv_close(3C), cconv_open(3C), cconvctl(3C), iconv(3C),
iconv_close(3C), iconv_open(3C), iconvctl(3C), iconvstr(3C),
attributes(7), standards(7)
NOTES
Note that the symbolic constants defined in the DESCRIPTION section,
cconv(3C), cconv_close(3C), cconv_open(3C), cconvctl(3C), iconvctl(3C),
and iconvstr(3C) are non-standard, Oracle Solaris proprietary inter‐
faces. While they might be available in other platforms, if portability
is important, they should not be used.
Oracle Solaris 11.4 10 Nov 2014 iconv.h(3HEAD)