svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
hook_nic_event(9s)
Kernel & Driver Data Structures hook_nic_event(9S)
NAME
hook_nic_event - data structure describing events related to network
interfaces
SYNOPSIS
#include <sys/neti.h>
#include <sys/hook.h>
#include <sys/hook_event.h>
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
The hook_nic_event structure contains fields that relate to an event
that has occurred and belongs to a network interface. This structure is
passed through to callbacks for NE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN
and NE_ADDRESS_CHANGE events.
A callback may not alter any of the fields in this structure.
STRUCTURE MEMBERS
net_data_t hne_family;
phy_if_t pkt_private;
lif_if_t hne_lif;
nic_event_t hne_event;
nic_event_data_t hne_data;
size_t hne_datalen;
The following fields are set for each event:
hne_family A valid reference for the network protocol that owns this
network interface and can be in calls to other net‐
info(9F) functions.
hne_nic The physical interface to which an event belongs.
hne_event A value that indicates the respective event. The current
list of available events is:
NE_PLUMB
an interface has just been created.
NE_UNPLUMB
An interface has just been destroyed and no more
events should be received for it.
NE_UP
An interface has changed the state to "up" and may
now generate packet events.
NE_DOWN
An interface has changed the state to "down" and will
no longer generate packet events.
NE_ADDRESS_CHANGE
An address on an interface has changed. hne_lif
refers to the logical interface for which the change
is occurring, hne_data is a pointer to a sockaddr
structure that is hne_datalen bytes long and contains
the new network address.
NE_IFINDEX_CHANGE
An interface index has changed. hne_lif refers to the
logical interface for which the change is occurring,
hne_data is a new ifindex value.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted
SEE ALSO
attributes(7), netinfo(9F)
Oracle Solaris 11.4 29 Sep 2009 hook_nic_event(9S)