svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
grantpt(3c)
Standard C Library Functions grantpt(3C)
NAME
grantpt - grant access to the slave pseudo-terminal device
SYNOPSIS
#include <stdlib.h>
int grantpt(int fildes);
DESCRIPTION
The grantpt() function changes the mode and ownership of the slave
pseudo-terminal device associated with its master pseudo-terminal coun‐
terpart. fildes is the file descriptor returned from a successful open
of the master pseudo-terminal device. The user ID of the slave is set
to the real UID of the calling process and the group ID is set to a
reserved group. The permission mode of the slave pseudo-terminal is set
to readable and writable by the owner and writable by the group.
RETURN VALUES
Upon successful completion, grantpt() returns 0. Otherwise, it returns
−1 and sets errno to indicate the error.
ERRORS
The grantpt() function may fail if:
EBADF The fildes argument is not a valid open file descriptor.
EINVAL The fildes argument is not associated with a master pseudo-
terminal device.
EACCES The corresponding slave pseudo-terminal device could not be
accessed.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe _ Standard‐
See standards(7).
SEE ALSO
open(2), ptsname(3C), unlockpt(3C), attributes(7), standards(7)
STREAMS Programming Guide
Oracle Solaris 11.4 14 Aug 2006 grantpt(3C)