svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getwc(3c)
Standard C Library Functions getwc(3C)
NAME
getwc - get wide character from a stream
SYNOPSIS
#include <stdio.h>
#include <wchar.h>
wint_t getwc(FILE *stream);
DESCRIPTION
The getwc() function is equivalent to fgetwc(3C), except that if it is
implemented as a macro it may evaluate stream more than once, so the
argument should never be an expression with side effects.
RETURN VALUES
Refer to fgetwc(3C).
ERRORS
Refer to fgetwc(3C).
USAGE
This interface is provided to align with some current implementations
and with possible future ISO standards.
Because it may be implemented as a macro, getwc() may treat incorrectly
a stream argument with side effects. In particular, getwc(*f++) may not
work as expected. Therefore, use of this function is not recommended;
fgetwc(3C) should be used instead.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityStandard _ MT-LevelMT-Safe
SEE ALSO
fgetwc(3C), attributes(7), standards(7)
Oracle Solaris 11.4 24 Jul 2002 getwc(3C)