svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getustack(2)
getustack(2) System Calls getustack(2)
NAME
getustack, setustack - retrieve or change the address of per-LWP stack
boundary information
SYNOPSIS
#include <ucontext.h>
int getustack(stack_t **spp);
int setustack(stack_t *sp);
DESCRIPTION
The getustack() function retrieves the address of per-LWP stack bound‐
ary information. The address is stored at the location pointed to by
spp. If this address has not been defined using a previous call to
setustack(), NULL is stored at the location pointed to by spp.
The setustack() function changes the address of the current thread's
stack boundary information to the value of sp.
RETURN VALUES
Upon successful completion, these functions return 0. Otherwise, −1 is
returned and errno is set to indicate the error.
ERRORS
These functions will fail if:
EFAULT The spp or sp argument does not refer to a valid address.
USAGE
Only implementors of custom threading libraries should use these func‐
tions to get and set the address of the stack bound to an internal per-
thread data structure. Other users should use stack_getbounds(3C) and
stack_setbounds(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.78i) |cw(2.72i) lw(2.78i) |lw(2.72i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe
SEE ALSO
stack_getbounds(3C), _stack_grow(3C), stack_inbounds(3C), stack_set‐
bounds(3C), stack_violation(3C), attributes(7)
Oracle Solaris 11.4 2 Nov 2004 getustack(2)