svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getpeername(3c)
Standard C Library Functions getpeername(3C)
NAME
getpeername - get the name of the peer socket
SYNOPSIS
#include <sys/socket.h>
int getpeername(int socket, struct sockaddr *restrict address,
socklen_t *restrict address_len);
DESCRIPTION
The getpeername() function retrieves the peer address of the specified
socket, stores this address in the sockaddr structure pointed to by the
address argument, and stores the length of this address in the object
pointed to by the address_len argument.
The caller is responsible for providing a pointer to a memory buffer of
suitable size in the address argument (typically a struct sock‐
addr_storage), and providing the size of that buffer in the value
pointed to by the address_len argument. If the actual length of the
address is greater than the length of the supplied sockaddr structure,
the stored address will be truncated.
If the protocol permits connections by unbound clients, and the peer is
not bound, then the value stored in the object pointed to by address is
unspecified.
RETURN VALUES
Upon successful completion, 0 is returned. Otherwise, −1 is returned
and errno is set to indicate the error.
ERRORS
The getpeername() function will fail if:
EBADF The socket argument is not a valid file descriptor.
EFAULT The address or address_len parameter can not be accessed
or written.
EINVAL The socket has been shut down.
ENOTCONN The socket is not connected or otherwise has not had the
peer prespecified.
ENOTSOCK The socket argument does not refer to a socket.
EOPNOTSUPP The operation is not supported for the socket protocol.
The getpeername() function may fail if:
ENOBUFS Insufficient resources were available in the system to com‐
plete the call.
ENOSR There were insufficient STREAMS resources available for the
operation to complete.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
accept(3C), bind(3C), getpeerucred(3C), getsockname(3C), socket(3C),
socket.h(3HEAD), attributes(7), standards(7)
HISTORY
The getpeername() function has been present since the initial release
of Solaris.
Oracle Solaris 11.4 2 Feb 2021 getpeername(3C)