svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getpassphrase(3c)
Standard C Library Functions getpass(3C)
NAME
getpass, getpassphrase - read a string of characters without echo
SYNOPSIS
#include <stdlib.h>
char *getpass(const char *prompt);
char *getpassphrase(const char *prompt);
XPG4, SUS, SUSv2
#include <unistd.h>
char *getpass(const char *prompt);
DESCRIPTION
The getpass() function opens the process's controlling terminal, writes
to that device the null-terminated string prompt, disables echoing,
reads a string of characters up to the next newline character or EOF,
restores the terminal state and closes the terminal.
The getpassphrase() function is identical to getpass(), except that it
reads and returns a string of up to 257 characters in length.
RETURN VALUES
Upon successful completion, getpass() returns a pointer to a null-ter‐
minated string of at most 9 bytes that were read from the terminal
device. If an error is encountered, the terminal state is restored and
a null pointer is returned.
ERRORS
The getpass() and getpassphrase() functions may fail if:
EINTR The function was interrupted by a signal.
EIO The process is a member of a background process attempting to
read from its controlling terminal, the process is ignoring
or blocking the SIGTTIN signal or the process group is
orphaned.
EMFILE OPEN_MAX file descriptors are currently open in the calling
process.
ENFILE The maximum allowable number of files is currently open in
the system.
ENXIO The process does not have a controlling terminal.
USAGE
The return value points to static data whose content may be overwritten
by each call.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface Stabilitygetpass() is Standard. _ MT-Lev‐
elUnsafe
SEE ALSO
attributes(7), standards(7)
Oracle Solaris 11.4 2 Sep 2003 getpass(3C)