svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getpagesize(3c)
Standard C Library Functions getpagesize(3C)
NAME
getpagesize - get system page size
SYNOPSIS
#include <unistd.h>
int getpagesize(void);
DESCRIPTION
The getpagesize() function returns the number of bytes in a page. Page
granularity is the granularity of many of the memory management calls.
The page size is a system page size and need not be the same as the
underlying hardware page size.
The getpagesize() function is equivalent to sysconf(_SC_PAGE_SIZE) and
sysconf(_SC_PAGESIZE). See sysconf(3C).
RETURN VALUES
The getpagesize() function returns the current page size.
ERRORS
No errors are defined.
USAGE
The value returned by getpagesize() need not be the minimum value that
malloc(3C) can allocate. Moreover, the application cannot assume that
an object of this size can be allocated with malloc().
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe
SEE ALSO
pagesize(1), brk(2), getrlimit(2), mmap(2), mprotect(2), munmap(2),
malloc(3C), msync(3C), sysconf(3C), attributes(7)
Oracle Solaris 11.4 27 Jun 2000 getpagesize(3C)