svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getisax(2)
getisax(2) System Calls getisax(2)
NAME
getisax - extract valid instruction set extensions
SYNOPSIS
#include <sys/auxv.h>
uint_t getisax(uint32_t *array, uint_t n);
DESCRIPTION
The getisax() function sets the vector array of n 32-bit integers to
contain the bits from the AV_xxx_yyy namespace of the given instruction
set architecture.
Values for AV_xxx_yyy for SPARC and SPARCV9, and their associated
descriptions, can be found in <sys/auxv_SPARC.h>.
Values for AV_xxx_yyy for i386 and AMD64, and their associated descrip‐
tions, can be found in <sys/auxv_386.h>.
RETURN VALUES
The getisax() function returns the maximum number of array elements
that contain non-zero values. This may be more than 'n'. The value n
may be zero and array may be NULL, in which case the number of array
elements will be returned and array will not be accessed.
EXAMPLES
Example 1 Use getisax() to determine if the SSE2 instruction set is
present.
In the following example, if the message is written, the SSE2 instruc‐
tion set is present and fully supported by the operating system.
uint_t n = getisax(NULL, 0);
uint_t *ui = calloc(n, sizeof(uint_t));
(void) getisax(ui, n);
if (ui[AV_HW1_IDX] & AV_386_SSE2) {
printf("SSE2 instruction set extension is present.\n");
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
isainfo(1), ld(1), pargs(1), attributes(7)
Oracle Solaris 11.4 Linkers and Libraries Guide
NOTES
Instruction extensions to the native platform ABI are also represented
by hardware capabilities. For a complete description of hardware capa‐
bilities, refer to the Oracle Solaris 11.4 Linkers and Libraries Guide.
Oracle Solaris 11.4 4 May 2020 getisax(2)