svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getipsecprotobynum(3c)
Standard C Library Functions getipsecprotobyname(3C)
NAME
getipsecprotobyname, getipsecprotobynum - query IPsec protocols entries
SYNOPSIS
#include <netdb.h>
int getipsecprotobyname(const char *proto_name);
char *getipsecprotobynum(int proto_num);
DESCRIPTION
Use the getipsecprotobyname() and getipsecprotobynum() functions to
obtain the IPsec algorithm mappings that are defined by ipsecalgs(8).
You can also use the getipsecprotobyname() and getipsecprotobynum()
functions in conjunction with getipsecalgbyname(3C) and getipsecal‐
gbynum(3C) to obtain information about the supported IPsec algorithms.
The IPsec algorithms and associated protocol name spaces are defined by
RFC 2407.
getipsecprotobyname() takes as an argument the name of an IPsec proto‐
col and returns its assigned protocol number. The character string
returned by the getipsecprotobyname() function must be freed by the
caller when it is no longer needed.
getipsecprotobynum() takes as an argument a protocol number and returns
the corresponding protocol name.
The following protocol numbers are pre-defined:
IPSEC_PROTO_ESP Defines the encryption algorithms (transforms) that
can be used by IPsec to provide data confidential‐
ity.
IPSEC_PROTO_AH Defines the authentication algorithms (transforms)
that can be used by IPsec to provide authentication.
PARAMETERS
proto_name A pointer to the name of an IPsec protocol.
proto_num A protocol number.
RETURN VALUES
The getipsecprotobyname() function returns a protocol number upon suc‐
cess, or −1 if the protocol specified does not exist.
The getipsecprotobynum() function returns a protocol name upon success,
or the NULL value if the protocol number specified does not exist.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelMT-Safe _ Interface StabilityCommitted
SEE ALSO
getipsecalgbyname(3C), getipsecalgbynum(3C), attributes(7), ipse‐
calgs(8)
Piper, D. RFC 2407, The Internet IP Security Domain of Interpretation
for ISAKMP. Network Working Group. November, 1998.
https://tools.ietf.org/html/rfc2407.
HISTORY
The getipsecprotobyname() and getipsecprotobynum() functions were added
to Oracle Solaris in the Solaris 10 3/05 release.
Oracle Solaris 11.4 2 Feb 2021 getipsecprotobyname(3C)