svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
getexecname(3c)
Standard C Library Functions getexecname(3C)
NAME
getexecname - return pathname of executable
SYNOPSIS
#include <stdlib.h>
const char *getexecname(void);
DESCRIPTION
The getexecname() function returns the pathname (the first argument of
one of the exec family of functions; see exec(2)) of the executable
that started the process.
Normally this is an absolute pathname, as the majority of commands are
executed by the shells that append the command name to the user's PATH
components. If this is not an absolute path, the output of getcwd(3C)
can be prepended to it to create an absolute path, unless the process
or one of its ancestors has changed its root directory or current work‐
ing directory since the last successful call to one of the exec family
of functions.
RETURN VALUES
If successful, getexecname() returns a pointer to the executables path‐
name; otherwise, it returns 0.
USAGE
The getexecname() function obtains the executable pathname from the
AT_SUN_EXECNAME aux vector. These vectors are made available to dynami‐
cally linked processes only.
A successful call to one of the exec family of functions will always
have AT_SUN_EXECNAME in the aux vector. The associated pathname is
guaranteed to be less than or equal to PATH_MAX, not counting the
trailing null byte that is always present.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ MT-LevelSafe
SEE ALSO
exec(2), getcwd(3C), attributes(7)
Oracle Solaris 11.4 17 Dec 1997 getexecname(3C)