get_cyclecount(9) 맨 페이지 - 윈디하나의 솔라나라

개요

섹션
맨 페이지 이름
검색(S)

get_cyclecount(9)

GET_CYCLECOUNT(9)        BSD Kernel Developer's Manual       GET_CYCLECOUNT(9)

NAME
     get_cyclecount — get the CPU's fast counter register contents

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <machine/cpu.h>

     uint64_t
     get_cyclecount(void);

DESCRIPTION
     The get_cyclecount() function uses a register available in most modern
     CPUs to return a value that is monotonically increasing inside each CPU.

     On SMP systems, there will be a number of separate monotonic sequences,
     one for each CPU running.  The value in the SMP case is selected from one
     of these sequences, dependent on which CPU was scheduled to service the
     request.

     The speed and the maximum value of each counter is CPU-dependent.  Some
     CPUs (such as the Intel 80486) do not have such a register, so
     get_cyclecount() on these platforms returns a (monotonic) combination of
     numbers represented by the structure returned by binuptime(9).

     The AMD64 and Intel 64 processors use the TSC register.

SEE ALSO
     binuptime(9)

HISTORY
     The get_cyclecount() function first appeared in FreeBSD 5.0.

AUTHORS
     This manual page was written by Mark Murray <markm@FreeBSD.org>.

BSD                             March 15, 2011                             BSD
맨 페이지 내용의 저작권은 맨 페이지 작성자에게 있습니다.
RSS ATOM XHTML 5 CSS3