svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fsetpos(3c)
Standard C Library Functions fsetpos(3C)
NAME
fsetpos - reposition a file pointer in a stream
SYNOPSIS
#include <stdio.h>
int fsetpos(FILE *stream, const fpos_t *pos);
DESCRIPTION
The fsetpos() function sets the file position indicator for the stream
pointed to by stream according to the value of the object pointed to by
pos, which must be a value obtained from an earlier call to fgetpos(3C)
on the same stream.
A successful call to fsetpos() function clears the end-of-file indica‐
tor for the stream and undoes any effects of ungetc(3C) on the same
stream. After an fsetpos() call, the next operation on an update stream
may be either input or output.
RETURN VALUES
The fsetpos() function returns 0 if it succeeds; otherwise it returns a
non-zero value and sets errno to indicate the error.
ERRORS
The fsetpos() function may fail if:
EBADF The file descriptor underlying stream is not valid.
ESPIPE The file descriptor underlying stream is associated with a
pipe, a FIFO, a socket, or a STREAMS device.
USAGE
The fsetpos() function has a transitional interface for 64-bit file
offsets. See lf64(7).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
lseek(2), fgetpos(3C), fopen(3C), fseek(3C), ftell(3C), rewind(3C),
ungetc(3C), attributes(7), lf64(7), standards(7)
Oracle Solaris 11.4 30 May 2014 fsetpos(3C)