svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fpclassify(3m)
Mathematical Library Functions fpclassify(3M)
NAME
fpclassify - classify real floating type
SYNOPSIS
c99 [ flag... ] file... -lm [ library... ]
#include <math.h>
int fpclassify(real-floating x);
DESCRIPTION
The fpclassify() macro classifies its argument value as NaN, infinite,
normal, subnormal, or zero. First, an argument represented in a format
wider than its semantic type is converted to its semantic type. Then
classification is based on the type of the argument.
RETURN VALUES
The fpclassify() macro returns the value of the number classification
macro appropriate to the value of its argument.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
math.h(3HEAD), isnan(3M), isfinite(3M), isinf(3M), isnormal(3M), sign‐
bit(3M), attributes(7), standards(7)
Solaris 11.4 27 Sept 2016 fpclassify(3M)