svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fgetwc(3c)
Standard C Library Functions fgetwc(3C)
NAME
fgetwc - get a wide-character code from a stream
SYNOPSIS
#include <stdio.h>
#include <wchar.h>
wint_t fgetwc(FILE*stream);
DESCRIPTION
The fgetwc() function obtains the next character (if present) from the
input stream pointed to by stream, converts that to the corresponding
wide-character code and advances the associated file position indicator
for the stream (if defined).
If an error occurs, the resulting value of the file position indicator
for the stream is indeterminate.
The fgetwc() function may mark the st_atime field of the file associ‐
ated with stream for update. The st_atime field will be marked for
update by the first successful execution of fgetwc(), fgetc(3C),
fgets(3C), fgetws(3C), fread(3C), fscanf(3C), getc(3C), getchar(3C),
gets(3C), or scanf(3C) using stream that returns data not supplied by a
prior call to ungetc(3C) or ungetwc(3C).
RETURN VALUES
Upon successful completion the fgetwc() function returns the wide-char‐
acter code of the character read from the input stream pointed to by
stream converted to a type wint_t.
For standard-conforming (see standards(7)) applications, if the end-of-
file indicator for the stream is set, fgetwc() returns WEOF whether or
not the stream is at end-of-file.
If a read error occurs, the error indicator for the stream is set,
fgetwc() returns WEOF and sets errno to indicate the error.
If an encoding error occurs, the error indicator for the stream is set,
fgetwc() returns WEOF, and errno is set to indicate the error.
ERRORS
The fgetwc() function will fail if data needs to be read and:
EAGAIN The O_NONBLOCK flag is set for the file descriptor under‐
lying stream and the process would be delayed in the
fgetwc() operation.
EBADF The file descriptor underlying stream is not a valid file
descriptor open for reading.
EINTR The read operation was terminated due to the receipt of a
signal, and no data was transferred.
EIO A physical I/O error has occurred, or the process is in a
background process group attempting to read from its con‐
trolling terminal and either the process is ignoring or
blocking the SIGTTIN signal or the process group is
orphaned.
EOVERFLOW The file is a regular file and an attempt was made to read
at or beyond the offset maximum associated with the corre‐
sponding stream.
The fgetwc() function may fail if:
ENOMEM Insufficient storage space is available.
ENXIO A request was made of a non-existent device, or the request
was outside the capabilities of the device.
EILSEQ The data obtained from the input stream does not form a valid
character.
USAGE
The ferror(3C) or feof(3C) functions must be used to distinguish
between an error condition and an end-of-file condition.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ CSIEnabled _ Interface StabilityCommitted _ MT-LevelMT-
Safe _ StandardSee standards(7).
SEE ALSO
fgetc(3C), feof(3C), ferror(3C), fgets(3C), fgetws(3C), fopen(3C),
fread(3C), fscanf(3C), getc(3C), getchar(3C), gets(3C), scanf(3C), set‐
locale(3C), ungetc(3C), ungetwc(3C), attributes(7), standards(7)
Oracle Solaris 11.4 7 Oct 2014 fgetwc(3C)