svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fgetpos(3c)
Standard C Library Functions fgetpos(3C)
NAME
fgetpos - get current file position information
SYNOPSIS
#include <stdio.h>
int fgetpos(FILE *stream, fpos_t *pos);
DESCRIPTION
The fgetpos() function stores the current value of the file position
indicator for the stream pointed to by stream in the object pointed to
by pos. The value stored contains unspecified information usable by
fsetpos(3C) for repositioning the stream to its position at the time of
the call to fgetpos().
RETURN VALUES
Upon successful completion, fgetpos() returns 0. Otherwise, it returns
a non-zero value and sets errno to indicate the error.
ERRORS
The fgetpos() function may fail if:
EBADF The file descriptor underlying stream is not valid.
ESPIPE The file descriptor underlying stream is associated with a
pipe, a FIFO, a socket, or a STREAMS device.
EOVERFLOW The current value of the file position cannot be repre‐
sented correctly in an object of type fpos_t.
USAGE
The fgetpos() function has a transitional interface for 64-bit file
offsets. See lf64(7).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityStandard
SEE ALSO
ftell(3C), fopen(3C), fsetpos(3C), rewind(3C), ungetc(3C),
attributes(7), lf64(7), standards(7)
Oracle Solaris 11.4 29 May 2014 fgetpos(3C)