svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fetestexcept(3m)
Mathematical Library Functions fetestexcept(3M)
NAME
fetestexcept - test floating-point exception flags
SYNOPSIS
c99 [ flag... ] file... -lm [ library... ]
#include <fenv.h>
int fetestexcept(int excepts);
DESCRIPTION
The fetestexcept() function determines which of a specified subset of
the floating-point exception flags are currently set. The excepts argu‐
ment specifies the floating-point status flags to be queried.
RETURN VALUES
The fetestexcept() function returns the value of the bitwise-inclusive
OR of the floating-point exception macros corresponding to the cur‐
rently set floating-point exceptions included in excepts.
ERRORS
No errors are defined.
EXAMPLES
Example 1 Example using fetestexcept()
The following example calls function f( ) if an invalid exception is
set, and then function g( ) if an overflow exception is set:
#include <fenv.h>
/* ... */
{
# pragma STDC FENV_ACCESS ON
int set_excepts;
feclearexcept(FE_INVALID | FE_OVERFLOW);
// maybe raise exceptions
set_excepts = fetestexcept(FE_INVALID | FE_OVERFLOW);
if (set_excepts & FE_INVALID) f();
if (set_excepts & FE_OVERFLOW) g();
/* ... */
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
fenv.h(3HEAD), feclearexcept(3M), fegetexceptflag(3M), attributes(7),
standards(7)
Solaris 11.4 27 Sept 2016 fetestexcept(3M)