svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fesetround(3m)
Mathematical Library Functions fegetround(3M)
NAME
fegetround, fesetround - get and set current rounding direction
SYNOPSIS
c99 [ flag... ] file... -lm [ library... ]
#include <fenv.h>
int fegetround(void);
int fesetround(int round);
DESCRIPTION
The fegetround() function gets the current rounding direction.
The fesetround() function establishes the rounding direction repre‐
sented by its argument round. If the argument is not equal to the value
of a rounding direction macro, the rounding direction is not changed.
RETURN VALUES
The fegetround() function returns the value of the rounding direction
macro representing the current rounding direction, or a negative value
if there is no such rounding direction macro or the current rounding
direction is not determinable.
The fegetround() function returns a 0 value if and only if the
requested rounding direction was established.
ERRORS
No errors are defined.
EXAMPLES
The following example saves, sets, and restores the rounding direction,
reporting an error and aborting if setting the rounding direction
fails:
Example 1 Save, set, and restore the rounding direction.
#include <fenv.h>
#include <assert.h>
void f(int round_dir)
{
#pragma STDC FENV_ACCESS ON
int save_round;
int setround_ok;
save_round = fegetround();
setround_ok = fesetround(round_dir);
assert(setround_ok == 0);
/* ... */
fesetround(save_round);
/* ... */
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
fenv.h(3HEAD), attributes(7), standards(7)
Solaris 11.4 27 Sept 2016 fegetround(3M)