svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fesetenv(3m)
Mathematical Library Functions fegetenv(3M)
NAME
fegetenv, fesetenv - get and set current floating-point environment
SYNOPSIS
c99 [ flag... ] file... -lm [ library... ]
#include <fenv.h>
int fegetenv(fenv_t *envp);
int fesetenv(const fenv_t *envp);
DESCRIPTION
The fegetenv() function attempts to store the current floating-point
environment in the object pointed to by envp.
The fesetenv() function attempts to establish the floating-point envi‐
ronment represented by the object pointed to by envp. The envp argument
points to an object set by a call to fegetenv() or feholdexcept(3M), or
equals a floating-point environment macro. The fesetenv() function does
not raise floating-point exceptions, but only installs the state of the
floating-point status flags represented through its argument.
RETURN VALUES
If the representation was successfully stored, fegetenv() returns 0.
Otherwise, it returns a non-zero value.
If the environment was successfully established, fesetenv() returns 0.
Otherwise, it returns a non-zero value.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
fenv.h(3HEAD), feholdexcept(3M), feupdateenv(3M), attributes(7), stan‐
dards(7)
NOTES
In a multithreaded program, the fegetenv() and fegetenv() functions
affect the floating point environment only for the calling thread.
These functions automatically install and deinstall SIGFPE handlers and
set and clear the trap enable mode bits in the floating point status
register as needed. If a program uses these functions and attempts to
install a SIGFPE handler or control the trap enable mode bits indepen‐
dently, the resulting behavior is not defined.
As described in fex_set_handling(3M), when a handling function
installed in FEX_CUSTOM mode is invoked, all exception traps are dis‐
abled (and will not be reenabled while SIGFPE is blocked). Thus,
attempting to change the environment from within a handler by calling
fesetenv or feupdateenv(3M) might not produce the expected results.
Solaris 11.4 29 Sept 2016 fegetenv(3M)