svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
feraiseexcept(3m)
Mathematical Library Functions feraiseexcept(3M)
NAME
feraiseexcept - raise floating-point exception
SYNOPSIS
c99 [ flag... ] file... -lm [ library... ]
#include <fenv.h>
int feraiseexcept(int excepts);
DESCRIPTION
The feraiseexcept() function attempts to raise the supported floating-
point exceptions represented by the excepts argument. The order in
which these floating-point exceptions are raised is unspecified.
RETURN VALUES
If excepts is 0 or if all the specified exceptions were successfully
raised, feraiseexcept() returns 0. Otherwise, it returns a non-zero
value.
ERRORS
No errors are defined.
USAGE
The effect is intended to be similar to that of floating-point excep‐
tions raised by arithmetic operations. Hence, enabled traps for float‐
ing-point exceptions raised by this function are taken.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
fenv.h(3HEAD), feclearexcept(3M), fegetexceptflag(3M), fetestex‐
cept(3M), attributes(7), standards(7)
Solaris 11.4 27 Sept 2016 feraiseexcept(3M)