svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
feof(3c)
Standard C Library Functions ferror(3C)
NAME
ferror, feof, clearerr, fileno - stream status inquiries
SYNOPSIS
#include <stdio.h>
int ferror(FILE *stream);
int feof(FILE *stream);
void clearerr(FILE *stream);
int fileno(FILE *stream);
DESCRIPTION
The ferror() function returns a non-zero value when an error has previ‐
ously occurred reading from or writing to the named stream (see
intro(3)). It returns 0 otherwise.
The feof() function returns a non-zero value when EOF has previously
been detected reading the named input stream. It returns 0 otherwise.
The clearerr() function resets the error indicator and EOF indicator to
0 on the named stream.
The fileno() function returns the integer file descriptor associated
with the named stream; see open(2).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
open(2), fopen(3C), stdio(3C), intro(3), attributes(7), standards(7)
Oracle Solaris 11.4 17 Feb 2005 ferror(3C)