svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
feholdexcept(3m)
Mathematical Library Functions feholdexcept(3M)
NAME
feholdexcept - save current floating-point environment
SYNOPSIS
c99 [ flag... ] file... -lm [ library... ]
#include <fenv.h>
int feholdexcept(fenv_t *envp);
DESCRIPTION
The feholdexcept() function saves the current floating-point environ‐
ment in the object pointed to by envp, clears the floating-point status
flags, and then installs a non-stop (continue on floating-point excep‐
tions) mode, if available, for all floating-point exceptions.
RETURN VALUES
The feholdexcept() function returns 0 if and only if non-stop floating-
point exception handling was successfully installed.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
fenv.h(3HEAD), fegetenv(3M), feupdateenv(3M), attributes(7), stan‐
dards(7)
NOTES
In a multithreaded program, the feholdexcept() function affects the
floating point environment only for the calling thread.
The feholdexcept() function automatically installs and deinstalls
SIGFPE handlers and sets and clears the trap enable mode bits in the
floating point status register as needed. If a program uses these func‐
tions and attempts to install a SIGFPE handler or control the trap
enable mode bits independently, the resulting behavior is not defined.
Solaris 11.4 27 Sept 2016 feholdexcept(3M)