svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
fegetexceptflag(3m)
Mathematical Library Functions fegetexceptflag(3M)
NAME
fegetexceptflag, fesetexceptflag - get and set floating-point status
flags
SYNOPSIS
cc [ flag... ] file... -lm [ library... ]
#include <fenv.h>
int fegetexceptflag(fexcept_t *flagp, int excepts);
int fesetexceptflag(const fexcept_t *flagp, int excepts);
DESCRIPTION
The fegetexceptflag() function attempts to store an implementation-
defined representation of the states of the floating-point status flags
indicated by the excepts argument in the object pointed to by the flagp
argument.
The fesetexceptflag() function attempts to set the floating-point sta‐
tus flags indicated by the excepts argument to the states stored in the
object pointed to by flagp. The value pointed to by flagp will have
been set by a previous call to fegetexceptflag() whose second argument
represented at least those floating-point exceptions represented by the
excepts argument. This function does not raise floating-point excep‐
tions but only sets the state of the flags.
RETURN VALUES
If the representation was successfully stored, fegetexceptflag()
returns 0. Otherwise, it returns a non-zero value.
If the excepts argument is 0 or if all the specified exceptions were
successfully set, fesetexceptflag() returns 0. Otherwise, it returns a
non-zero value.
ERRORS
No errors are defined.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i)
ATTRIBUTE TYPEATTRIBUTE VALUE _ Interface StabilityCommitted _ Avail‐
abilitysystem/library/math _ MT-LevelMT-Safe _ StandardSee stan‐
dards(7).
SEE ALSO
fenv.h(3HEAD), feclearexcept(3M), feraiseexcept(3M), fesetexcept‐
flag(3M), attributes(7), standards(7)
Solaris 11.4 27 Sept 2016 fegetexceptflag(3M)