svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
elf_strptr(3elf)
elf_strptr(3ELF) ELF Library Functions elf_strptr(3ELF)
NAME
elf_strptr - make a string pointer
SYNOPSIS
cc [ flag ... ] file ... -lelf [ library ... ]
#include <libelf.h>
char *elf_strptr(Elf *elf, size_t section, size_t offset);
DESCRIPTION
The elf_strptr() function converts a string section offset to a string
pointer. elf identifies the file in which the string section resides,
and section identifies the section table index for the strings.
elf_strptr() normally returns a pointer to a string, but it returns a
null pointer when elf is null, section is invalid or is not a section
of type SHT_STRTAB, the section data cannot be obtained, offset is
invalid, or an error occurs.
EXAMPLES
Example 1 A sample program of calling elf_strptr() function.
A prototype for retrieving section names appears below. The file header
specifies the section name string table in the e_shstrndx member. The
following code loops through the sections, printing their names.
/* handle the error */
if ((ehdr = elf32_getehdr(elf)) == 0) {
return;
}
ndx = ehdr->e_shstrndx;
scn = 0;
while ((scn = elf_nextscn(elf, scn)) != 0) {
char *name = 0;
if ((shdr = elf32_getshdr(scn)) != 0)
name = elf_strptr(elf, ndx, (size_t)shdr->sh_name);
printf("'%s'\n", name? name: "(null)");
}
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
elf(3ELF), elf32_getshdr(3ELF), elf32_xlatetof(3ELF), elf_get‐
data(3ELF), libelf(3LIB), attributes(7)
NOTES
When applied to a compressed string table section, elf_strptr() will
return pointers to uncompressed strings, without causing the string ta‐
ble section to be uncompressed.
A program may call elf_getdata() to retrieve an entire string table
section. For some applications, that would be both more efficient and
more convenient than using elf_strptr().
Oracle Solaris 11.4 10 December 2015 elf_strptr(3ELF)