svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
elf64_fsize(3elf)
elf32_fsize(3ELF) ELF Library Functions elf32_fsize(3ELF)
NAME
elf32_fsize, elf64_fsize - return the size of an object file type
SYNOPSIS
cc [ flag ... ] file ... -lelf [ library ... ]
#include <libelf.h>
size_t elf32_fsize(Elf_Type type, size_t count, uint_t ver);
size_t elf64_fsize(Elf_Type type, size_t count, uint_t ver);
DESCRIPTION
elf32_fsize() gives the size in bytes of the 32-bit file representation
of count data objects with the given type. The library uses version ver
to calculate the size. See elf(3ELF) and elf_version(3ELF).
Constant values are available for the sizes of fundamental types:
Elf_Type File Size Memory Size
ELF_T_ADDR ELF32_FSZ_ADDR sizeof(Elf32_Addr)
ELF_T_BYTE 1 sizeof(unsigned char)
ELF_T_HALF ELF32_FSZ_HALF sizeof(Elf32_Half)
ELT_T_OFF ELF32_FSZ_OFF sizeof(Elf32_Off)
ELF_T_SWORD ELF32_FSZ_SWORD sizeof(Elf32_Sword)
ELF_T_WORD ELF32_FSZ_WORD sizeof(Elf32_Word)
elf32_fsize() returns 0 if the value of type or ver is unknown. See
elf32_xlatetof(3ELF) for a list of the type values.
For the 64−bit class, replace 32 with 64 as appropriate.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe
SEE ALSO
elf(3ELF), elf32_xlatetof(3ELF), elf_version(3ELF), libelf(3LIB),
attributes(7)
Oracle Solaris 11.4 8 September 2014 elf32_fsize(3ELF)