svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
dlpi_walk(3dlpi)
Data Link Provider Interface Library Functions dlpi_walk(3DLPI)
NAME
dlpi_walk - traverse DLPI links
SYNOPSIS
cc [ flag... ] file... -ldlpi [ library... ]
#include <libdlpi.h>
void dlpi_walk(dlpi_walkfunc_t *fn, void *arg, uint_t flags);
typedef boolean_t dlpi_walkfunc_t(const char *name, void *arg);
PARAMETERS
fn Function to invoke for each link. Arguments are:
name The name of the DLPI interface.
arg The arg parameter passed in to dlpi_walk().
arg An opaque argument that is passed transparently to the
user-supplied fn() function.
flags DLPI_ALLZONES
Include non-global zone DLPI links in the walk (global
zone only).
DESCRIPTION
The dlpi_walk() function visits all DLPI links. The walk terminates
either when all links have been visited or when fn() returns B_TRUE.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
libdlpi(3LIB), attributes(7)
Oracle Solaris 11.4 7 Apr 2011 dlpi_walk(3DLPI)