svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_walk_node(3devinfo)
Device Information Library Functions di_walk_node(3DEVINFO)
NAME
di_walk_node - traverse libdevinfo device nodes
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
int di_walk_node(di_node_t root, uint_t flag, void *arg,
int (*node_callback)(di_node_t node, void *arg));
DESCRIPTION
The di_walk_node() function visits all nodes in the subtree rooted at
root. For each node found, the caller-supplied function node_callback()
is invoked. The return value of node_callback() specifies subsequent
walking behavior.
PARAMETERS
arg Pointer to caller-specific data.
flag Specifies walking order, either DI_WALK_CLDFIRST (depth first)
or DI_WALK_SIBFIRST (breadth first). DI_WALK_CLDFIRST is the
default.
node The node being visited.
root The handle to the root node of the subtree to visit.
RETURN VALUES
Upon successful completion, di_walk_node() returns 0. Otherwise, -1 is
returned and errno is set to indicate the error.
The node_callback() function can return one of the following:
DI_WALK_CONTINUE Continue walking.
DI_WALK_PRUNESIB Continue walking, but skip siblings and their
child nodes.
DI_WALK_PRUNECHILD Continue walking, but skip subtree rooted at cur‐
rent node.
DI_WALK_TERMINATE Terminate the walk immediately.
ERRORS
The di_walk_node() function will fail if:
EINVAL Invalid argument.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
di_init(3DEVINFO), libdevinfo(3LIB), attributes(7)
Writing Device Drivers in Oracle Solaris 11.4
Oracle Solaris 11.4 16 Jan 2009 di_walk_node(3DEVINFO)