svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_prop_next(3devinfo)
Device Information Library Functions di_prop_next(3DEVINFO)
NAME
di_prop_next - libdevinfo property traversal function
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
di_prop_t di_prop_next(di_node_t node, di_prop_t prop);
PARAMETERS
node Handle to a device node.
prop Handle to a property.
DESCRIPTION
The di_prop_next() function returns a handle to the next property on
the property list. If prop is DI_PROP_NIL, the handle to the first
property is returned.
RETURN VALUES
Upon successful completion, di_prop_next() returns a handle. Otherwise
DI_PROP_NIL is returned and errno is set to indicate the error.
ERRORS
The di_prop_next() function will fail if:
EINVAL Invalid argument.
ENOTSUP The snapshot does not contain property information.
ENXIO There are no more properties.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
di_init(3DEVINFO), libdevinfo(3LIB), attributes(7)
Writing Device Drivers in Oracle Solaris 11.4
Oracle Solaris 11.4 1 Dec 1998 di_prop_next(3DEVINFO)