svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_prom_prop_next(3devinfo)
Device Information Library Functions
di_prom_prop_data(3DEVINFO)
NAME
di_prom_prop_data, di_prom_prop_next, di_prom_prop_name - access PROM
device information
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
di_prom_prop_t di_prom_prop_next(di_prom_handle_t ph, di_node_t node,
di_prom_prop_t prom_prop);
char *di_prom_prop_name(di_prom_prop_t prom_prop);
int di_prom_prop_data(di_prom_prop_t prom_prop, uchar_t **prop_data);
PARAMETERS
node Handle to a device node in the snapshot of kernel device
tree.
ph PROM handle
prom_prop Handle to a PROM property.
prop_data Address of a pointer.
DESCRIPTION
The di_prom_prop_next() function obtains a handle to the next property
on the PROM property list associated with node. If prom_prop is
DI_PROM_PROP_NIL, the first property associated with node is returned.
The di_prom_prop_name() function returns the name of the prom_prop
property.
The di_prom_prop_data() function returns the value of the prom_prop
property. The return value is a non-negative integer specifying the
size in number of bytes in prop_data.
All memory allocated by these functions is managed by the library and
must not be freed by the caller.
RETURN VALUES
The di_prom_prop_data() function returns the number of bytes in
prop_data and prop_data is updated to point to a byte array containing
the property value. If 0 is returned, the property is a boolean prop‐
erty and the existence of this property indicates the value is true.
The di_prom_prop_name() function returns a pointer to a string that
contains the name of prom_prop.
The di_prom_prop_next() function returns a handle to the next PROM
property. DI_PROM_PROP_NIL is returned if no additional properties
exist.
ERRORS
See openprom(4D) for a description of possible errors.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
openprom(4D), attributes(7)
Writing Device Drivers in Oracle Solaris 11.4
Oracle Solaris 11.4 1 Dec 1998
di_prom_prop_data(3DEVINFO)