svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_prom_init(3devinfo)
Device Information Library Functions di_prom_init(3DEVINFO)
NAME
di_prom_init, di_prom_fini - create and destroy a handle to the PROM
device information
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
di_prom_handle_t di_prom_init(void);
void di_prom_fini(di_prom_handle_t ph);
PARAMETERS
ph Handle to prom returned by di_prom_init().
DESCRIPTION
For device nodes whose nodeid value is DI_PROM_NODEID (see
di_nodeid(3DEVINFO)), additional properties can be retrieved from the
PROM. The di_prom_init() function returns a handle that is used to
retrieve such properties. This handle is passed to
di_prom_prop_lookup_bytes(3DEVINFO) and di_prom_prop_next(3DEVINFO).
The di_prom_fini() function destroys the handle and all handles to the
PROM device information obtained from that handle.
RETURN VALUES
Upon successful completion, di_prom_init() returns a handle. Otherwise,
DI_PROM_HANDLE_NIL is returned and errno is set to indicate the error.
ERRORS
The di_prom_init() sets errno function to any error code that can also
be set by openprom(4D) or malloc(3C).
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
malloc(3C), di_nodeid(3DEVINFO), di_prom_prop_lookup_bytes(3DEVINFO),
di_prom_prop_next(3DEVINFO), libdevinfo(3LIB), openprom(4D),
attributes(7)
Oracle Solaris 11.4 1 Dec 1998 di_prom_init(3DEVINFO)