svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_path_prop_lookup_bytes(3devinfo)
Device Information Library Functions
di_path_prop_lookup_bytes(3DEVINFO)
NAME
di_path_prop_lookup_bytes, di_path_prop_lookup_int64s,
di_path_prop_lookup_ints, di_path_prop_lookup_strings - search for a
path property
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
int di_path_prop_lookup_bytes(di_path_t path,
const char *prop_name);
int di_path_prop_lookup_int64s(di_path_t path,
const char *prop_name);
int di_path_prop_lookup_ints(di_path_t path,
const char *prop_name, char **prop_data);
int di_path_prop_lookup_strings(di_path_t path,
const char *prop_name, char **prop_data);
PARAMETERS
path The handle to a path node in a di_init(3DEVINFO).
prop_name The name of property for which to search.
prop_data For di_path_prop_lookup_bytes(), the address to a pointer
to an array of unsigned characters containing the property
data.
For di_path_prop_lookup_int64(), the address to a pointer
to an array of 64-bit integers containing the property
data.
For di_path_prop_lookup_ints(), the address to a pointer
to an array of integers containing the property data.
For di_path_prop_lookup_strings(), the address to a
pointer to a buffer containing a concatenation of null-
terminated strings containing the property data.
DESCRIPTION
These functions return the value of a known property name and type.
All memory allocated by these functions is managed by the library and
must not be freed by the caller.
RETURN VALUES
If the property is found, the number of entries in prop_data is
returned. Otherwise, -1 is returned and errno is set to indicate the
error.
ERRORS
These functions will fail if:
EINVAL One of the arguments is invalid.
ENOTSUP The snapshot contains no property information.
ENXIO The path property does not exist.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
di_init(3DEVINFO), libdevinfo(3LIB), attributes(7)
Writing Device Drivers in Oracle Solaris 11.4
Oracle Solaris 11.4 15 May 2008
di_path_prop_lookup_bytes(3DEVINFO)