svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
di_minor_next(3devinfo)
Device Information Library Functions di_minor_next(3DEVINFO)
NAME
di_minor_next - libdevinfo minor node traversal functions
SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ]
#include <libdevinfo.h>
di_minor_t di_minor_next(di_node_t node, di_minor_t minor);
PARAMETERS
minor Handle to the current minor node or DI_MINOR_NIL.
node Device node with which the minor node is associated.
DESCRIPTION
The di_minor_next() function returns a handle to the next minor node
for the device node node. If minor is DI_MINOR_NIL, a handle to the
first minor node is returned.
RETURN VALUES
Upon successful completion, a handle to the next minor node is
returned. Otherwise, DI_MINOR_NIL is returned and errno is set to indi‐
cate the error.
ERRORS
The di_minor_next() function will fail if:
EINVAL Invalid argument.
ENOTSUP Minor node information is not available in snapshot.
ENXIO End of minor node list.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelSafe
SEE ALSO
libdevinfo(3LIB), attributes(7)
Writing Device Drivers in Oracle Solaris 11.4
Oracle Solaris 11.4 1 Dec 1998 di_minor_next(3DEVINFO)